Back to overview
Downtime

Some services are down

Nov 07 at 01:53pm CET
Affected services
Wallet
Wallet API
Connect

Resolved
Nov 07 at 02:26pm CET

Fix has been rolled out and systems are stable again.

Updated
Nov 07 at 02:01pm CET

We have identified the statement that is causing high load on the server. A fix is being rolled out.

Created
Nov 07 at 01:53pm CET

The wallet API is unstable at the moment due to high load on our database server.